大智慧股评师主图指标公式

爱股道股票资讯网(提示您即将浏览的内容是:大智慧股评师主图指标公式input:p1(10,0,999,1),p2(20,0,999,1),p3(60,0,999,1),p4(144,0,999,1);MA1:MA(CLOSE,P1);MA2:MA…

爱股道股票资讯网(https://www.igudao.com)提示您即将浏览的内容是:大智慧股评师主图指标公式

  input:p1(10,0,999,1),p2(20,0,999,1),p3(60,0,999,1),p4(144,0,999,1);

  MA1:MA(CLOSE,P1);

  MA2:MA(CLOSE,P2);

  MA3:MA(CLOSE,P3);

  MA4:MA(CLOSE,P4);

  BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

  MA5:ma(c,5),COLORFF50FF,linethick2;

  partline(MA5,MA5>=ref(MA5,1),rgb(255,0,0),MA5

  { DRAWGBKLAST(MA5>=ref(MA5,1),STRIP(RGB(0,150,0),RGB(150,0,0),1));

  DRAWGBKLAST(MA5<=ref(MA5,1),STRIP(RGB(150,0,0),RGB(0,150,0),1));}

  VAR326:=IF(CLOSE>REF(CLOSE,1),88,0);

  VAR327:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND VAR326>0, 91, 0);

  DRAWTEXT(VAR327>90,LOW*0.99,'追'),COLORYELLOW;

  STICKLINE(VAR327>90,OPEN,CLOSE,3,0),COLORYELLOW;

  STICKLINE(VAR327>90,LOW,HIGH,0,0 ),COLORYELLOW;

  {45度异动}

  x1:=(C+L+H)/3;

  bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10;

  ema8:=ema(c,8);

  DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,8),1),10),

  ema8,'∠45上升'),coloryellow;

  AAA:=(3*C+H+L+O)/6;

  VAR41:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;

  TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR41;

  立桩量:=FILTER(TJ1,5);

  TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));

  突破:=TJ2=1;

  TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));

  三天法则:=TJ3=1;

  成立:=三天法则 AND 突破;

  条件成立:=FILTER(成立,3);

  DRAWTEXT(条件成立,L*0.99,'立桩量'),COLORYELLOW;

  var1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

  var2:=REF(var1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

  var3:=REF(var2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

  var4:=REF(var3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

  var5:=REF(var4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

  var6:=REF(var5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

  var7:=REF(var6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

  var8:=REF(var7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

  var9:=REF(var8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

  varA:=REF(var9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

  varB:=REF(varA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

  varC:=REF(varB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

  varD:=CLOSE

  varE:=REF(varD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

  varF:=REF(varE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

  var10:=REF(varF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

  var11:=REF(var10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

  var12:=REF(var11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

  var13:=REF(var12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

  var14:=REF(var13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

  var15:=REF(var14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

  var16:=REF(var15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

  var17:=REF(var16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

  var18:=REF(var17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

  var19:=REF(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

  var14 OR var15 OR var16 OR var17 OR var18,1) AND var1;

  var1A:=REF(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

  var8 OR var9 OR varA OR varB OR varC,1) AND varD;

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),8,0),COLOR00FFFF;{黄色}

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),8,0),COLORFF00FF;{粉红色}

  黄底买入:var19,linethick0,COLOR00ffff;

  粉顶卖出:var1A,linethick0,COLORFF50FF;

  红色持股:0,linethick0,COLORRED;

  绿色持币:0,linethick0,COLOR00d900;

  DRAWICON(var19,REF(CLOSE,1)*0.99,7),ALIGN1;

  DRAWICON(var1A,REF(CLOSE,1)*1.02,8),ALIGN1;

  DRAWTEXTABS(2,5,'所属板块:'+BKNAME),COLORFF50FF,linethick1;

  流通盘大小:=FINANCE2(37)/1000000*100;

  DRAWTEXTABS(2,20,'流通盘大小:'+NUMTOSTRN(流通盘大小,2)+'亿'+' 电子盲制作'),LINETHICK1,COLORRED;

  每股收益:=FINANCE2(3);

  每股市盈率:=DYNAINFO(39);

  每股净资产:=FINANCE2(4);

  销售毛利率:=FINANCE2(12);

  主营收入同比:=FINANCE2(11);

  净利润同比增长:=FINANCE2(10);

  DRAWTEXTABS(160,35,'每股收益:'+NUMTOSTRN(每股收益,2)+'元'),COLOR00FF00;

  DRAWTEXTABS(160,50,'每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),COLORRED;

  DRAWTEXTABS(160,65,'每股净资产:'+NUMTOSTRN(每股净资产,2)+'元'),COLORRED;

  DRAWTEXTABS(2,35,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),LINETHICK1,COLOR00FF00;

  DRAWTEXTABS(2,50,'主营收入同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),LINETHICK1,ColorYELLOW;

  DRAWTEXTABS(2,65,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),LINETHICK1,COLOR00FF00;

  DRAWTEXTABS(3,80,'历史最高价:'+HHV(HIGH,0)),Colorred;

  DRAWTEXTABS(3,95,'历史最低价:'+LLV(LOW,0)),ColorAFFF00;

  A4:=MA(CLOSE,20);

  A5:=(CLOSE > MA(CLOSE,5));

  A6:=(MA(CLOSE,5) > MA(CLOSE,10));

  A7:=(CLOSE > MA(CLOSE,10));

  A8:=(MA(CLOSE,5) > MA(CLOSE,20));

  A9:=(CLOSE > MA(CLOSE,20));

  A10:=REF(A4,1);

  A11:=(A4 > A10);

  AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10)))

  + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10)))

  + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));

  DSLX:=(CLOSE / INDEXC);

  DSLX1:=MA(DSLX,5);

  DSLX2:=MA(DSLX,10);

  V1:=MA(VOL,5);

  V2:=MA(VOL,10);

  阻力位:=IF((CLOSE > 200),(CLOSE * 1.01),(CLOSE * 1.07));

  阻力位1:=IF((CLOSE < 10),(CLOSE * 1.05),阻力位);

  止损位:=IF((CLOSE > 200),(CLOSE * 0.99),(CLOSE * 0.93));

  止损位1:=IF((CLOSE < 10),(CLOSE * 0.95),止损位);

  TJTS1:=BARSTATUS=2 and c<200;

  TJTS2:=BARSTATUS=2 and c>200;

  k2:=hhv(h,barslast(DISPSTATUS=1)+1);

  DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 >=V2)) AND (DSLX >=DSLX1)) ,k2*0.99,'该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),ALIGN2,colorDC143C;

  DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >=DSLX1)) ,k2*0.99,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),ALIGN2,colorDC143C;

  DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),ALIGN2,colorDC143C;

  DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 <=V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),ALIGN2,color0000FF;

  DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >=V2)) AND (DSLX >=DSLX1)) ,k2*0.99,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),ALIGN2,color00FF00;

  DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >=DSLX1)) ,k2*0.99,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),ALIGN2,color00FF00;

  DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >=V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股放量下跌,走势明显偏弱,离场观望。 '),ALIGN2,color00FF00;

  DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股缩量下跌,走势偏弱,离场观望。 '),ALIGN2,color00FF00;

  DRAWTEXT(TJTS1 and ((((AVX >=1) AND (REF(AVX,1) > 0)) AND (V1 >=V2)) AND (DSLX >=DSLX1)) ,k2*0.99,'该股形态良好,强势明显,量能充足,可以继续持有。 '),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS1 and ((((AVX >=1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >=DSLX1)) ,k2*0.99,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS1 and ((((AVX >=1) AND (REF(AVX,1) > 0)) AND (V1 >=V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS1 and ((((AVX >=1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股走势趋弱,量能不足,减持大部分筹码。 '),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >=V2)) AND (DSLX >=DSLX1)) ,k2*0.99,'该股形态不佳,注意成交量的变化,但目前不适合参与。 '),ALIGN2;

  DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >=DSLX1)) ,k2*0.99,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),ALIGN2;

  DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >=V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),ALIGN2;{本文 来源:'www.55188.com '}

  DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股走势太弱,没有参与价值。 '),ALIGN2;

  DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >=V2)) ,k2*0.99,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),ALIGN2,color0000FF;

  DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >=V2)) ,k2*0.98,' 如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),ALIGN2,color0000FF;

  DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.99,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),ALIGN2,color0000FF;

  DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.98,' 可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),ALIGN2,color0000FF;

  DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 >=V2)) ,k2*0.99,'大盘形态走坏,重仓者可以减去大部分仓位。 '),ALIGN2,color00FF00;

  DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 < V2)) ,k2*0.99,'大盘缩量调整,注意风险,短线清仓观望。 '),ALIGN2,color00FF00;

  DRAWTEXT(TJTS2 and (((AVX >=1) AND (REF(AVX,1) > 0)) AND (V1 >=V2)) ,k2*0.99,'大盘走势良好,量能理想,可以继续持有强势股。 '),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS2 and (((AVX >=1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) ,k2*0.99,'大盘形态良好,但量能稍显不足,随时准备减仓。 '),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >=V2)) ,k2*0.99,'大盘趋势不明,注意成交量变化,目前不适宜进场。 '),ALIGN2;

  DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) ,k2*0.99,'大盘趋势向下,量能萎缩,不适合进场。 '),ALIGN2;

  分界:(HORILINE(L<=LLV(LOW,60),LOW,L<=LLV(Low,60))),COLORWHITE;

  VAR2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)

  STICKLINE(VAR2,H,L,1,0),COLORFF00FF,LINETHICK2;{底位黄色};

  大智慧股评师主图指标公式

爱股道股票资讯网(https://www.igudao.com)提醒您:股市有风险,投资需谨慎,您浏览的内容是大智慧股评师主图指标公式。

为您推荐

留言与评论(共有 条评论)
   
验证码:
联系我们

联系我们

13932226327

在线咨询: QQ交谈

邮箱: 49268044@qq.com

工作时间:周一至周日,9:00-17:30

关注微信
微信扫一扫关注我们

微信扫一扫领取强势牛股

关注微博
返回顶部