大智慧MACDKDJ指标公式

爱股道股票资讯网(提示您即将浏览的内容是:大智慧MACD+KDJ指标公式INPUT:LONG(26,20,100),SHORT(12,5,40),M(9,2,60),N(9,1,100),M1(3,2,40),M2(3,2,40);DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);DEA:=EM…

爱股道股票资讯网(https://www.igudao.com)提示您即将浏览的内容是:大智慧MACD+KDJ指标公式

  INPUT:LONG(26,20,100),SHORT(12,5,40),M(9,2,60),N(9,1,100),M1(3,2,40),M2(3,2,40);

  DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);

  DEA:=EMA(DIFF,M);MACD:=2*(DIFF-DEA);

  RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

  K:SMA(RSV,M1,1);D:SMA(K,M2,1);J:3*K-2*D;KX:=BARSSINCE(CLOSE);

  HKMAX:=MAX(HHV(K,KX),MAX(HHV(D,KX),HHV(J,KX)));

  LKMIN:=MIN(LLV(K,KX),MIN(LLV(D,KX),LLV(J,KX)));

  KDBL:=(HKMAX+LKMIN)/2;KDC:=HKMAX-LKMIN;

  FDBL:=(MAX(HHV(DIFF,KX),MAX(HHV(DEA,KX),HHV(MACD,KX)))+MIN(LLV(DIFF,KX),MIN(LLV(DEA,KX),LLV(MACD,KX))))/100;

  FDC:=MAX(HHV(DIFF,KX),MAX(HHV(DEA,KX),HHV(MACD,KX)))-MIN(LLV(DIFF,KX),MIN(LLV(DEA,KX),LLV(MACD,KX)));

  DF:(DIFF-FDBL)*(KDC/FDC)+KDBL,COLOR0099FF,LAYER2,LINETHICK2;

  {www.gupang.com 股旁网_大智慧股票指标公式}

  DA:(DEA-FDBL)*(KDC/FDC)+KDBL,COLORD89837,LAYER2,LINETHICK2;

  MACDA:=(MACD-FDBL)*(KDC/FDC)+KDBL;SH:=(0-FDBL)*(KDC/FDC)+KDBL;

  50,COLORGRAY,DOTLINE; 0,COLORRED,POINTDOT; 100,COLORGREEN,POINTDOT;

  STICKLINE(MACD>=REF(MACD,1) AND MACD>0,50,(MACDA-SH)+50,3,0),COLORRED;

  STICKLINE(MACD0,50,(MACDA-SH)+50,3,0),COLOR00DDDD;

  STICKLINE(MACD>REF(MACD,1) AND MACD<0,50,(MACDA-SH)+50,3,0),COLORCYAN;

  STICKLINE(MACD<=REF(MACD,1) AND MACD<0,50,(MACDA-SH)+50,3,0),COLORFF4422;

  大智慧MACD+KDJ指标公式

爱股道股票资讯网(https://www.igudao.com)提醒您:股市有风险,投资需谨慎,您浏览的内容是大智慧MACD+KDJ指标公式。

为您推荐

留言与评论(共有 条评论)
   
验证码:
联系我们

联系我们

13932226327

在线咨询: QQ交谈

邮箱: 49268044@qq.com

工作时间:周一至周日,9:00-17:30

关注微信
微信扫一扫关注我们

微信扫一扫领取强势牛股

关注微博
返回顶部