通达信布林宝塔指标公式

爱股道股票资讯网(提示您即将浏览的内容是:通达信布林宝塔指标公式NA:=STRCAT(CON2STR(YEAR,0),'年');YA:=STRCAT(CON2STR(MONTH,0),'月');RA:=STRCAT(CON2STR(DAY,0),'日');SJ:=STRCAT(STRCAT(NA,YA),RA);DRAWTEXT_FIX(C>0,0.88,0,0,SJ);{箱体线}N…

爱股道股票资讯网(https://www.igudao.com)提示您即将浏览的内容是:通达信布林宝塔指标公式

  NA:=STRCAT(CON2STR(YEAR,0),' 年 ');

  YA:=STRCAT(CON2STR(MONTH,0),' 月 ');

  RA:=STRCAT(CON2STR(DAY,0),' 日 ');

  SJ:=STRCAT(STRCAT(NA,YA), RA);

  DRAWTEXT_FIX(C>0,0.88,0,0,SJ);

  {箱体线}

  N:=7;

  T1:=CONST(LLVBARS(LOW,N));

  T1HIGH:=CONST(REF(HIGH,T1));

  CC:=CONST(CURRBARSCOUNT);

  T2:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T1)) AND (HIGH>T1HIGH)));

  T2HIGH:=CONST(REF(HIGH,T2));

  T3:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T2)) AND (HIGH>T2HIGH)));

  T3HIGH:=CONST(REF(HIGH,T3));

  突破杀入线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),LINETHICK1,COLORYELLOW;

  DRAWTEXT(ISLASTBAR, T3HIGH, ' 杀入线!'),LINETHICK1,COLORYELLOW;

  AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);

  BA:=EMA(AB,5);

  A1{高}:=REFDATE(REF(HHV(H,96),5),DATE);

  B1{低}:=REFDATE(REF(LLV(L,96),5),DATE);

  DY{中}:=((A1)+(B1))/2;

  箱顶:IF(AB>0 AND AB-BA<=0,A1,A1),COLORGREEN,DOTLINE;

  箱腰:IF(AB>0 AND AB-BA<=0,DY,DY),COLORYELLOW,DOTLINE;

  箱低:IF(AB>0 AND AB-BA<=0,B1,B1),COLORRED,DOTLINE;

  VARAA:=IF(CLOSE>150,91.3,0.913);

  突破:INTPART(CLOSE/VARAA )*VARAA,POINTDOT,LINETHICK4,COLORRED;

  再突破:突破+VARAA,POINTDOT,LINETHICK4,COLOR00FF00 ;

  回踩:(突破+再突破)/2,POINTDOT,COLORWHITE,LINETHICK4;

  STICKLINE(CROSS(ZIG(3,5),REF(ZIG(3,5),1)),箱低,箱腰,0.1,-1),COLORRED;

  STICKLINE(CROSS(REF(ZIG(3,5),1),ZIG(3,5)),箱顶,箱腰,0.1,-1),COLORGREEN;

  DRAWICON(CROSS(ZIG(3,5),REF(ZIG(3,5),1)),箱腰,1);

  DRAWICON(CROSS(REF(ZIG(3,5),1),ZIG(3,5)),箱腰,2);

  EE:=(H+L+O+2*C)/5;

  CRTP:=EE+(H-L);

  CRZL:=2*EE-L;

  CRZC:=2*EE-H;

  CRFZ:=EE-(H-L);

  高:CONST(CRTP),COLORRED;

  阻:CONST(CRZL),COLORC7C9FF;

  支:CONST(CRZC),COLOR7C9CFF;

  反:CONST(CRFZ),COLORDD00DD;

  DRAWTEXT(ISLASTBAR, 反, ' 反转价'),LINETHICK1,COLORDD00DD;

  DRAWTEXT(ISLASTBAR, 支, ' 支撑'),LINETHICK1,COLOR7C9CFF;

  DRAWTEXT(ISLASTBAR, 阻, ' 阻力'),LINETHICK1,COLORC7C9FF;

  DRAWTEXT(ISLASTBAR, 高, ' 高破线'),LINETHICK1,COLORGREEN;

  均线:=EXPMA(C,12),COLORGRAY,LINETHICK2;

  日:=50;

  昨前:=3;

  高2:=REF(HHV(H,日),昨前);

  低2:=REF(LLV(L,日),昨前);

  H4:=高2-(高2-低2)*0.618;

  H5:=高2-(高2-低2)*0.809;

  支撑80.9%:REFDATE(H5,DATE),COLORRED;

  支撑61.8%:REFDATE(H4,DATE),COLORGREEN,;

  STICKLINE(CURRBARSCOUNT=1,支撑80.9%,支撑80.9%,300,-1),COLORGREEN;

  STICKLINE(CURRBARSCOUNT=1,支撑61.8%,支撑61.8%,300,-1),COLORRED;

  WH1:=IF(L=LLV(L,9),L,0);

  WH2:=CONST(BARSLAST(WH1!=0));

  WH3:=CONST(IF(WH2=0,H,REF(H,WH2)));

  WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1);

  WH5:=CONST(IF(WH4=0,H,REF(H,WH4)));

  WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1);

  WH7:IF(CURRBARSCOUNT<=WH2+10,CONST(IF(WH6=0,H,REF(H,WH6))),DRAWNULL),COLORRED,DOTLINE;

  STICKLINE(CURRBARSCOUNT<=WH2+1 AND L=LLV(L,9),O,C,3,0),COLORRED;

  DRAWTEXT(CURRBARSCOUNT=WH2+10,WH7,'LINE'),COLORRED;

  DRAWTEXT(ISLASTBAR,WH7,' 进场'),COLORRED;

  WH8:IF(CURRBARSCOUNT<=WH2+1,IF(L=LLV(L,9),L,DRAWNULL),DRAWNULL),CIRCLEDOT;

  H81:=IF(H=HHV(H,9),H,DRAWNULL);

  H82:=CONST(BARSLAST(H81!=DRAWNULL));

  H83:=CONST(IF(H82=0,L,REF(L,H82)));

  H84:=CONST(REF(BARSLAST(L

  H85:=CONST(IF(H84=0,L,REF(L,H84)));

  H86:=CONST(REF(BARSLAST(L

  H87:=IF(CURRBARSCOUNT<=H82+10,CONST(IF(H86=0,L,REF(L,H86))),DRAWNULL),DOTLINE;

  H88:=IF(CURRBARSCOUNT<=H82+1,IF(H=HHV(H,9),H,DRAWNULL),DRAWNULL),CIRCLEDOT;

  DRAWTEXT(CURRBARSCOUNT=H82+10,H87,'LINE'),COLORYELLOW;

  DRAWTEXT(ISLASTBAR,H87,'止损'),COLORYELLOW;

  DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);

  DEA:=EMA(DIF,9);

  AAA:=(DIF-DEA)*2*60;

  起爆:=CROSS(AAA-REF(AAA,1),15);

  DRAWTEXT(起爆,MA(L,3),'↖........ 暴涨'),COLORYELLOW,LINETHICK2;

  LC:=REF((O+H+L+2*C)/5,1);

  {绝密买点}

  A81:=EMA(C,3),COLORWHITE;

  A82:=EMA(C,5),COLORYELLOW;

  A83:=EMA(C,7),COLORMAGENTA;

  A84:=EMA(C,12),COLORGREEN;

  A85:=EMA(C,20),COLORRED;

  A86:=EMA(C,50),COLORBLUE,LINETHICK2;

  SS8:=CROSS(A81,A85) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 ;

  SSS8:=CROSS(A81,A85) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;

  DRAWICON(SS8 ,MA(L,3),5);

  DRAWTEXT(SS8,MA(L,3),'↖绝密买点'),COLORYELLOW;

  ZYX1:="DMI.PDI"(12,6);

  ZYX2:="DMI.MDI"(12,6);

  ZYX3:=ZYX1>65 AND ZYX1>REF(ZYX1,1);

  ZYX4:=LLV(ZYX1,0);

  ZYX5:=BARSLAST(ZYX4=ZYX1);

  ZYX6:=(0-REF(ZYX2,4))/(ZYX4-REF(ZYX2,ZYX5))>2;

  ZYX7:=ZYX1>REF(ZYX1,1);

  ZYX8:=VOL>2*MA(VOL,30);

  ZYX9:="DMI.ADX"(12,6);

  ZYXA:="DMI.ADXR"(12,6);

  ZYXB:=CLOSE>MA(CLOSE,30) AND CLOSE

  ZYXC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);

  ZYXD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))

  {ZYXE:=0-"MACD.DIFF"(7,21,3);}

  ZYXF:=TROUGHBARS(3,15,1)<4;

  ZYX10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);

  ZYX11:=IF(ZYXF=1,50,0);

  ZYX12:=CROSS(ZYX2,ZYX1) AND CROSS(ZYXA,ZYX9);

  ZYX13:=CROSS(ZYX2,ZYX1) AND CROSS(ZYX9,ZYXA);

  ZYX14:=ZYXB AND ZYXC AND ZYXD AND ZYX10 AND ZYX6 AND ZYX7 AND ZYX8*50;

  ZYX15:=BARSLAST(CROSS(ZYX2,ZYX1)=1);

  ZYX16:=BARSLAST(CROSS(ZYX1,ZYX2)=1);

  ZYX17:=HHV(ZYX1,ZYX16);

  ZYX18:=BARSLAST(ZYX1=ZYX17);

  {STICKLINE(FILTER(ZYXF=1,5),50,0,10,0),COLORRED;}

  ZYX19:=ZYX3 OR ZYX12 OR ZYX13*100;

  ZYX1A:=ZYX13*100;

  DRAWICON(FILTER(ZYXF=1,3),MA(L,3),23);

  DRAWTEXT(FILTER(ZYXF=1,3),箱低,'■■铁底■■'),COLORGREEN;

  {量能平台}

  ND:=10;

  PTD:=CONST(LLVBARS(V,ND));

  TDPX:IF(CURRBARSCOUNT<=ND,CONST(IF(PTD=0,O,REF(O,PTD))),DRAWNULL),COLORFF0000;

  IF(CURRBARSCOUNT=PTD+1,TDPX,DRAWNULL),CIRCLEDOT,COLORFF0000,LINETHICK2;

  DRAWTEXT(ISLASTBAR,TDPX,' 【地平线】'),COLORFF0000;

  G21:=30;

  T112:=CONST(HHVBARS(V,G21));

  T122:=IF(CURRBARSCOUNT<=G21+7,CONST(IF(T112=0,H,REF(H,T112))),DRAWNULL);

  T122A:=IF(CURRBARSCOUNT=T112+1,T122,DRAWNULL),CIRCLEDOT,COLORWHITE;

  DRAWTEXT(ISLASTBAR,T122,' 30天量能平台'),COLORWHITE;

  W10:=10;

  TW1:=CONST(HHVBARS(V,W10));

  TW0:=IF(CURRBARSCOUNT<=W10+7,CONST(IF(TW1=0,C,REF(C,TW1))),DRAWNULL);

  TW0A:=IF(CURRBARSCOUNT=TW1+1,TW0,DRAWNULL),CIRCLEDOT,COLORWHITE;

  DRAWTEXT(ISLASTBAR,TW0,' 10量能平台'),COLORWHITE;

  W20:=20;

  TW20:=CONST(HHVBARS(V,W20));

  TW22:=IF(CURRBARSCOUNT<=W20+7,CONST(IF(TW20=0,C,REF(C,TW20))),DRAWNULL);

  TW22A:=IF(CURRBARSCOUNT=TW20+1,TW22,DRAWNULL),COLORWHITE;

  DRAWTEXT(ISLASTBAR,TW22,' 20量能平台'),COLORWHITE;

  {股旁网 www.gupang.com 股票指标公式}

  MW:=10;

  MW1:=CONST(LLVBARS(V,MW));

  MW0:=IF(CURRBARSCOUNT<=MW+7,CONST(IF(MW1=0,O,REF(O,MW1))),DRAWNULL);

  MW0A:=IF(CURRBARSCOUNT=MW1+1,MW0,DRAWNULL),CIRCLEDOT,COLORWHITE;

  DRAWTEXT(ISLASTBAR,MW0,' 地量反弹量能平台'),COLORWHITE;

  {N1:=18;N2:=36;N3:=55;}

  EM1:=EMA(C,18),NODRAW;

  EM2:=EMA(C,36),COLORRED;

  EM3:=EMA(C,55),COLORGREEN;

  TJ8:=BETWEEN(EM2,EM1,EM3);

  {DRAWICON(TJ8=0,L,14);}

  B18:='<-----------------财富平台';

  DRAWTEXT(VOL=HHV(VOL,20),C ,B18),COLORRED;

  {超跌反弹}

  RSV:=(CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*100;

  短期底部:=LLV(OPEN,30);

  K:=SMA(RSV,3,1);

  D:=SMA(K,3,1);

  J:=(3*K-2*D),LINETHICK2;

  D2:=SMA(J,3,1)*0.82;

  VAR72:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

  VAR73:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

  VAR74:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

  VAR75:=(VAR72+2*VAR73+3*VAR74)/6;

  DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA2:=EMA(DIFF,6);

  MACD超跌2:=(COUNT(DIFF

  DRAWTEXT(CROSS(J,-3),MA(L,3),'↖.................. 超跌反弹'),COLORGREEN;

  {DRAWICON( FILTER(CROSS(J,D2),20),D2+0.02 ,1);};

  {突破盘整}

  W1:=C=HHV(C,20);

  W2:=BARSLAST(W1);

  W3:=IF(W2>0,REF(C,W2),REF(C,W2));

  W4:=CROSS(C,REF(W3,1));

  突破盘整:=W4 AND COUNT(W4,5)=1;

  DRAWTEXT(突破盘整>0,MA(L,3),'↙....... 突破盘整'),COLORRED;

  C6:=REF(C,1);

  涨停:=IF((C-C6)*100/C6>=(10-0.01*100/C6),1,0);

  STICKLINE(涨停,OPEN,CLOSE,1,0),COLORYELLOW;

  STICKLINE(涨停,H,L,0,0),COLORYELLOW;

  DRAWTEXT(涨停,MA(H,3),' ↙. . ..涨停'),COLORYELLOW;

  RSI1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;

  SELL2:=(CROSS(88,RSI1));

  DRAWTEXT(SELL2,MA(H,3),'↙★出'),COLOR00FF00;

  VB1:=C-REF(C,1);

  VB2:=100*EMA(EMA(VB1,6),6)/EMA(EMA(ABS(VB1),6),6);

  VB3:=IF(LLV(VB2,2)=LLV(VB2,7) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);

  VB4:=FILTER(VB3=1,5);

  DRAWTEXT(VB4,MA(L,3),'↖★买'),COLOR00FFFF;

  {N 1 100 20 M 1 100 32 P1 1 100 80 P2 1 100 100}

  VARD1:=(C+H+O+L)/4;

  卖出:=XMA(VARD1,20)*(1+80/1000),COLORFFFFFF,LINETHICK3;

  买入:=XMA(VARD1,32)*(1-100/1000),COLOR0000FF,LINETHICK3;

  机会来临:=REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),COLORF00FF0,LINETHICK2;

  RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K2:=REF(MA(RSV2,3),1)+(RSV2-REF(MA(RSV2,3),1))/3;

  DD2:=REF(MA(K2,3),1)+(K2-REF(MA(K2,3),1))/3;

  J2:=3*K2-2*DD2;

  BB1:=EMA(J2,5);

  BB2:=REF(BB1,1);

  金叉:=CROSS(BB1,BB2);

  DRAWTEXT(CROSS(C,卖出),MA(H,3),' ↙卖出'),COLOR00FFFF;

  DRAWTEXT(CROSS(C,买入) AND BB1>BB2 AND C>REF(O,2),MA(L,3),'↖买入'),COLOR0000FF;

  DRAWICON(CROSS(C,买入) AND 金叉 AND 机会来临 ,MA(L,3),13);

  DRAWTEXT(CROSS(C,买入) AND 金叉 AND 机会来临,MA(L,3),'↖【绝杀点】'),COLOR00FF00;

  {绝杀}

  F:=EMA(CLOSE,10)-EMA(CLOSE,21);

  A:=EMA(F,8);

  MD:=(F-A)*2;

  ZQ:=BARSLAST(CROSS(F,A) AND A<=0.05)+1;

  LZ:=BARSLASTCOUNT(MD1;

  HZ:=BARSLASTCOUNT(MD>REF(MD,1))>1;

  LZQ:=BARSLASTCOUNT(LZ);

  HZQ:=BARSLASTCOUNT(HZ);

  LZQTJ:=COUNT(LZQ,ZQ);

  HZQTJ:=COUNT(HZQ,ZQ);

  NQR:=REF(CLOSE,4);

  SRZF:=((CLOSE-NQR)/NQR)*100,NODRAW;

  绝杀黑马:=REF(LZQTJ,1)>=2 AND REF(HZQTJ,1)>=3 AND HZQTJ=0 AND LZQTJ=0 AND SRZF>2,LINETHICK2;

  DRAWTEXT(绝杀黑马,MA(L,3),'↖★绝杀黑马'),COLOR00FFFF;

  箱顶@:箱顶+箱顶*0.02,COLORBLACK;

  通达信布林宝塔指标公式

爱股道股票资讯网(https://www.igudao.com)提醒您:股市有风险,投资需谨慎,您浏览的内容是通达信布林宝塔指标公式。

为您推荐

留言与评论(共有 条评论)
   
验证码:
联系我们

联系我们

13932226327

在线咨询: QQ交谈

邮箱: 49268044@qq.com

工作时间:周一至周日,9:00-17:30

关注微信
微信扫一扫关注我们

微信扫一扫领取强势牛股

关注微博
返回顶部