通达信小护士防空洞指标公式

爱股道股票资讯网(提示您即将浏览的内容是:通达信小护士防空洞指标公式VARTIME:=IF(YEAR>=2050ANDMONTH>=11ANDDAY>=07,0,1);VARDTIME:=IF(YEAR=2050ANDMONTH=11ANDDAY=06,1,0);DRAWTEXT(VARDTIME,115,''),COLOR008000;DRAWTEXT(…

爱股道股票资讯网(https://www.igudao.com)提示您即将浏览的内容是:通达信小护士防空洞指标公式

  VARTIME:=IF(YEAR>=2050 AND MONTH>=11 AND DAY>=07,0,1);

  VARDTIME:=IF(YEAR=2050 AND MONTH=11 AND DAY=06,1,0);

  DRAWTEXT(VARDTIME,115,''),COLOR008000;

  DRAWTEXT(VARDTIME,100,''),COLOR008000;

  DRAWTEXT(VARDTIME,85,''),COLOR008000;

  DRAWTEXT(VARDTIME,70,''),COLOR008000;

  DRAWTEXT(VARDTIME,45,''),COLOR008000;

  QW1:=(HIGH+LOW+CLOSE*2)/4*VARTIME;

  QW3:=EMA(QW1,10)*VARTIME;

  QW4:=STD(QW1,10)*VARTIME;

  QW5:=(QW1-QW3)*100/QW4*VARTIME;

  QW6:=EMA(QW5,5)*VARTIME;

  RK7:=EMA(QW6,10)*VARTIME;

  涨:EMA(QW6,10)+100/2-5,LINETHICK1,COLORRED;

  跌:EMA(涨,4),LINETHICK1,COLORFFFF34;

  多线:IF(CROSS(涨,跌) AND 跌<-10,30,0),LINETHICK1,COLORFF00FF;

  空线:IF(CROSS(跌,80),70,100),COLOR0099FF,LINETHICK1;

  买1:EMA(跌,4)*VARTIME,COLORWHITE;

  买2:EMA(买1,4)*VARTIME,COLORGREEN;

  买M3:=EMA(买2,4)*VARTIME,COLORYELLOW;

  买M4:=EMA(买M3,4)*VARTIME,COLORCC9900;

  -10,POINTDOT,COLOR888888,LINETHICK2;

  80,POINTDOT,COLOR888888,LINETHICK2;

  STICKLINE(涨

  STICKLINE(涨

  STICKLINE(涨

  STICKLINE(涨

  STICKLINE(涨

  STICKLINE(涨

  STICKLINE(涨

  STICKLINE(涨

  STICKLINE(涨

  {股旁网-股票公式网站 WWW.GUPANG.COM}

  STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),0,0) ,COLOR00BBFF;

  STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),8,0) ,COLOR0011FF;

  STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),7,0) ,COLOR0022FF;

  STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),6,0) ,COLOR0044FF;

  STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),5,0) ,COLOR0066FF;

  STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),4,0) ,COLOR0088FF;

  STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),3,0) ,COLOR0099FF;

  STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),2,0) ,COLOR00AAFF;

  STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),1,0) ,COLOR00BBFF;

  DRAWICON(多线,30,1),COLORFF00FF;

  DRAWICON(CROSS(跌,80),70,2),COLORGREEN;

  DRAWTEXT(CROSS(涨,跌) AND 跌<20 AND 跌>-10,40,'买入'),COLORCCFF99;

  DRAWTEXT(多线>0,-20,'看涨'),COLOR0000FF;

  VAR811:=SUMBARS(VOL,FINANCE(7)*100)*VARTIME;

  VAR822:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL)*VARTIME;

  VAR883:=(CLOSE-VAR822)/VAR822*100*VARTIME;

  VAR884:=HHV(VAR883,VAR811)*VARTIME;

  VAR885:=LLV(VAR883,VAR811)*VARTIME;

  VAR886:=(VAR883-VAR885)/(VAR884-VAR885)*100*VARTIME;

  K:=SMA(VAR886,3,1)*VARTIME;

  D:=SMA(K,3,1)*VARTIME;

  J:=3*K-2*D;

  MA1:=MA(J,3)*VARTIME,COLORGREEN;

  STICKLINE(FILTER(J>MA1 AND J<=3,5)=1 AND 跌<0,涨,涨+20,6,0),COLORYELLOW;

  DRAWTEXT(FILTER(J>MA1 AND J<=3,5)=1 AND 跌<0,60,'考虑买进'),COLORFFFFFF;

  VAR1:=MA(CLOSE,152);

  VAR2:=MA(CLOSE,194);

  VAR3:=VAR2+2*STD(CLOSE,170);

  VAR4:=VAR1+2*STD(CLOSE,170);

  顶:(CLOSE>VAR3)*13*10,COLORBLUE,LINETHICK2;

  VAR6:=EMA(HHV(HIGH,500),21);

  VAR7:=EMA(HHV(HIGH,250),21);

  VAR8:=EMA(HHV(HIGH,90),21);

  VAR9:=EMA(LLV(LOW,500),21);

  VARA:=EMA(LLV(LOW,250),21);

  VARB:=EMA(LLV(LOW,90),21);

  VARC:=EMA((VAR9*0.96+VARA*0.96+VARB*0.96+VAR6*0.558+VAR7*0.558+VAR8*0.558)/6,21);

  VARD:=EMA((VAR9*1.25+VARA*1.23+VARB*1.2+VAR6*0.55+VAR7*0.55+VAR8*0.65)/6,21);

  VARE:=EMA((VAR9*1.3+VARA*1.3+VARB*1.3+VAR6*0.68+VAR7*0.68+VAR8*0.68)/6,21);

  VARF:=EMA((VARC*3+VARD*2+VARE)/6*1.738,21);

  VAR10:=REF(LOW,1);

  VAR11:=SMA(ABS(LOW-VAR10),3,1)/SMA(MAX(LOW-VAR10,0),3,1)*100;

  VAR12:=EMA(IF(CLOSE*1.35<=VARF,VAR11*10,VAR11/10),3);

  VAR13:=LLV(LOW,30);

  VAR14:=HHV(VAR12,30);

  VAR15:=IF(MA(CLOSE,58),1,0);

  VAR16:=EMA(IF(LOW<=VAR13,(VAR12+VAR14*2)/2,0),3)/618*VAR15;

  VAR17:=IF(VAR16>50,50,VAR16)/3.82*6;

  VAR18:=HHV(HIGH,30);

  VAR19:=LLV(LOW,30);

  NL:=EMA((CLOSE-VAR19)/(VAR18-VAR19)*100,5)/8*10,COLORYELLOW,LINETHICK2;

  VAR1A:=(EMA(AMOUNT,5)/EMA(VOL,5)/100-EMA(AMOUNT,125)/EMA(VOL,125)/100)/(EMA(AMOUNT,5)/EMA(VOL,5)/100)<-0.4;

  VAR1B:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

  VAR1C:=SMA(VAR1B,3,1);

  VAR1D:=SMA(VAR1C,3,1);

  VAR1E:=(-100)*(HHV(HIGH,52)-CLOSE)/(HHV(HIGH,52)-LLV(LOW,52));

  VAR1F:=COUNT(VAR1A,5)>=1 AND (VAR1E<-99.9 OR VAR1D<15 AND VAR1C<12);

  VAR20:=VOL/FINANCE(7);

  VAR21:=100*WINNER(CLOSE);

  VAR22:=MA(VAR21,3);

  VAR23:=MA(VAR20,34);

  VAR24:=VAR22

  VAR25:=SUM(IF(CLOSE>REF(CLOSE,1),1,0),0);

  VAR26:=SUMBARS(VOL,CAPITAL);

  VAR27:=IF(CLOSE>LLV(CLOSE,VAR26),1,-1)*IF(VAR25>LLV(VAR25,VAR26),1,-1);

  VAR28:=COUNT(IF(VAR27=-1,1,0)=1,8)>2;

  VAR29:=(CLOSE-DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100)))/DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100))*100<-18;

  VAR2A:=(CLOSE-MIN(REF(CLOSE,5)*0.865,REF(CLOSE,21)*0.772))/CLOSE<0.01;

  VAR2B:=VAR28 AND VAR29 AND VAR2A;

  VAR2C:=VOL/CAPITAL>=0.02 AND VOL/CAPITAL<=0.2 AND OPEN=1.105;

  VAR2D:=VAR2C AND COUNT(VAR2C,5)=1;

  VAR2E:=VAR2B OR VAR2C;

  VAR2F:=REF(CLOSE,1);

  VAR30:=SMA(MAX(CLOSE-VAR2F,0),7,1)/SMA(ABS(CLOSE-VAR2F),7,1)*100;

  VAR31:=SMA(MAX(CLOSE-VAR2F,0),13,1)/SMA(ABS(CLOSE-VAR2F),13,1)*100;

  VAR32:=VAR30<20 AND VAR31<25;

  VAR33:=VAR32;

  VAR34:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE

  VAR35:=IF(CLOSE>LLV(CLOSE,VAR26),1,-1);

  VAR36:=IF(VAR34>LLV(VAR34,VAR26),1,-1);

  VAR37:=VAR35*VAR36;

  VAR38:=IF(VAR37=-1,1,0);

  VAR39:=VAR38 AND CLOSE=LLV(CLOSE,120) AND VAR21

  VAR3A:=IF(FILTER(VAR1F AND VAR24 AND VAR2E AND VAR33 AND VAR39>0,4),70,0);

  DRAWTEXT(FILTER(VAR24 AND VAR2E AND VAR33 OR VAR33 AND VAR39,1),VAR2*4-13,'抄底'),COLORRED;

  STICKLINE(IF(VAR24 AND VAR2E AND VAR33 OR VAR33 AND VAR39,35,0),0,VAR2*4-4,15,0);

  VAR3B:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;

  VAR3C:=SMA(VAR3B,3,1);

  VAR3D:=SMA(VAR3C,3,1);

  VAR3E:=SMA(VAR3D,3,1);

  VAR3F:=CROSS(VAR3D,VAR3E) AND VAR3D<20;

  VAR40:=CROSS(VAR3E,VAR3D) AND VAR3D>80;

  VAR41:=5;

  DRAWTEXT(CROSS(VAR41,NL),30,'★做底'),COLORWHITE;

  VAR42:="RSI#WEEK"(12,12,12);

  VAR43:="RSI#WEEK"(55,55,55);

  VAR44:=REF(CLOSE,1);

  VAR45:=SMA(MAX(CLOSE-VAR44,0),6,1)/SMA(ABS(CLOSE-VAR44),6,1)*100;

  VAR46:=FILTER(VAR40,5)=1 AND BARSLAST(CROSS(VAR42,VAR43) AND VAR42<=60)>=20;

  STICKLINE(CROSS(VAR42,VAR43) AND VAR42<=60,0,VAR2*15+5,3,0),COLORMAGENTA;

  DRAWTEXT(CROSS(VAR42,VAR43) AND VAR42<=60,(VAR2*12+3)/1,'加仓'),COLORMAGENTA;

  STICKLINE(CROSS(84,VAR45),0,VAR2*15+3,5,1),COLORGREEN;

  STICKLINE(VAR46,VAR2*15+10,10,6,0.3),COLORGREEN ;

  {IF(CROSS(84,VAR45),DRAWTEXT(CROSS(84,VAR45),80,'防空警报 '),IF(VAR46,DRAWTEXT(VAR46,100,'减仓'),0)),COLORGREEN ,;}

  DRAWTEXT(CROSS(84,VAR45),80,'防空警报'),COLORGREEN ,;

  DRAWTEXT(VAR46,100,'减仓'),COLORGREEN ,;

  通达信小护士防空洞指标公式

爱股道股票资讯网(https://www.igudao.com)提醒您:股市有风险,投资需谨慎,您浏览的内容是通达信小护士防空洞指标公式。

为您推荐